Автор Тема: Нет выхода звука 5.1  (Прочитано 2917 раз)

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Нет выхода звука 5.1
« : 06 Августа 2016, 15:34:50 »
Работают выходы фронт пр, лев и центр.
Тыла и саббуфера нет.
Эквалайзер проверял, раздельного тыла нет, сурраунд 100.
ОС Матунту 14.04 Т32-112
АМД - Е350 + видеокарта НВидиа.
Звук вывожу по оптике на ресивер.
Проблема в драйвере, я думаю, т.к.в настройках вывода звука есть только варианты "стерео" и "дуплекс"
« Последнее редактирование: 06 Августа 2016, 15:59:30 от Кулиш Евгений »

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Re: Нет выхода звука 5.1
« Ответ #1 : 06 Августа 2016, 15:35:15 »
~$ inxi -A
Audio:     Card-1 NVIDIA GF119 HDMI Audio Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.2.0-42-generic

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Re: Нет выхода звука 5.1
« Ответ #2 : 06 Августа 2016, 15:49:26 »
AlsaMixer v1.0.27.2
│   Карта: HDA ATI SB                                             │
│     Чип: Realtek ALC887-VD

Оффлайн ivm

  • Ветеран
  • *****
  • Сообщений: 1520
Re: Нет выхода звука 5.1
« Ответ #3 : 06 Августа 2016, 16:15:04 »
Насчёт звука могу сказать следующее: если я соединю аудиокарту с сабвуфером оптическим кабелем, то у меня не работает звук 5.1. Он у меня работает только на аналоговых кабелях. Это особенность моей звуковой карты под Linux.
Вы картинку теста видите?

Своё железо Вы должны лучше всех знать. Как расположены выходы для различных звуковых схем для Азалии набор цветных разъёмов и т.д. Оптическим может быть только вход звука. У меня на картах есть как вход, так и выход. Разберитесь сначала с документацией на своё оборудование.

 
Что непонятно спрашиваем, если всё понятно - пользуемся.
Что бы ни случилось, всё будет хорошо!

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Re: Нет выхода звука 5.1
« Ответ #4 : 06 Августа 2016, 17:17:18 »
Насчёт звука могу сказать следующее: если я соединю аудиокарту с сабвуфером оптическим кабелем, то у меня не работает звук 5.1. Он у меня работает только на аналоговых кабелях. Это особенность моей звуковой карты под Linux.
У меня оптика выводит цифровой сигнал на ресивер, а уже ресивер делит на каналы.
Вы картинку теста видите?
Я видел такую картинку, когда в настройках звука был вариант 5.1 (До Матунту, на мультимедийных сборках)

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Re: Нет выхода звука 5.1
« Ответ #5 : 06 Августа 2016, 17:25:09 »
Я думаю, что вопрос именно в драйвере.
Поскольку система 14.04, возможно он уже устаревший.
Возможно вопрос в ядре.
В нете есть варианты решений, но они не для Матунту.
Нынешняя переустановка системы и настройка происходят именно потому, что уронил систему, воспользовавшись не авторским советом...
Система работала, но настройка делалась примерно 2 года назад и решение не зафиксировал, потому сейчас и протоколирую...

Оффлайн ivm

  • Ветеран
  • *****
  • Сообщений: 1520
Re: Нет выхода звука 5.1
« Ответ #6 : 06 Августа 2016, 17:55:32 »
А журнальчик-то вести не лишнее, записывая найденные с трудом решения, чтобы не потерять безвозвратно, или делитесь ими на форуме, чтобы другим легче было да и самому можно вспомнить.
Насколько понимаю, проблема с опознаванием того, что подключено к ресиверу. Найдёте, опишите с указанием модели ресивера.
Что непонятно спрашиваем, если всё понятно - пользуемся.
Что бы ни случилось, всё будет хорошо!

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Re: Нет выхода звука 5.1
« Ответ #7 : 07 Августа 2016, 20:09:36 »
Нашёл в нете советы:
1. "переустановить alsa-base и alsa-utils."
Не помогло...
2. удалить pulseaudio
Не помогло...
3. установить Volti
Не помогло...
4. Доустановить пакеты:
"1.pulseaudio
2.pulseaudio-esound-compat
3.pulseaudio-module-gconf
4.pulseaudio-module-x11
5.pulseaudio-module-zeroconf
6.pulseaudio-utils
7.pulseaudio-module-bluetooth"
Не помогло...
« Последнее редактирование: 07 Августа 2016, 21:08:52 от Кулиш Евгений »

Оффлайн vita

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 2363
  • Да будет свет!
Re: Нет выхода звука 5.1
« Ответ #8 : 07 Августа 2016, 20:17:25 »
опишите с указанием модели ресивера.
Модель ресивера засекречена?
Делай с нами, делай как мы, делай лучше нас!

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Re: Нет выхода звука 5.1
« Ответ #9 : 07 Августа 2016, 20:24:38 »
опишите с указанием модели ресивера.
Модель ресивера засекречена?
Sony STR-DE598

Оффлайн ivm

  • Ветеран
  • *****
  • Сообщений: 1520
Re: Нет выхода звука 5.1
« Ответ #10 : 07 Августа 2016, 20:47:42 »
Посмотрел описание интерфейсов Вашего ресивера.
Цитировать
Интерфейсы:
Входы
композитный x3, компонентный x2, коаксиальный x1, оптический x2, 5.1CH x1, линейный x5
Выходы
сабвуфер x1, композитный x2, компонентный x1, наушники x1, линейный x2
Выход на сабвуфер у Вас есть, значит звук 2.1 гарантирован, а про тыловой динамик упоминаний нет.
Вы упомянули, что у Вас где-то работало. Если не секрет, то где?
Что непонятно спрашиваем, если всё понятно - пользуемся.
Что бы ни случилось, всё будет хорошо!

Оффлайн ivm

  • Ветеран
  • *****
  • Сообщений: 1520
Re: Нет выхода звука 5.1
« Ответ #11 : 07 Августа 2016, 21:01:56 »
По ссылке человек пишет отзыв, что тюльпанами (RCA) пользуется. Поддержка под Windows 10 гарантируется.
Что непонятно спрашиваем, если всё понятно - пользуемся.
Что бы ни случилось, всё будет хорошо!

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Re: Нет выхода звука 5.1
« Ответ #12 : 07 Августа 2016, 21:04:25 »
Посмотрел описание интерфейсов Вашего ресивера.
СпасиБо!
Задействованы следующие интерфейсы:
Входы
оптический и 5.1CH[/quote]
Выход на сабвуфер у Вас есть,
Есть 2 фронта, 2 тыла, центр и буфер.
Вы упомянули, что у Вас где-то работало. Если не секрет, то где?
Пару лет назад (до Матунту) какая-то сборка на базе Убунту, скачанная с ex.ua
Но она же не дружила с wi-fi на ноутбуке, потому весь парк был переведен на Матунту, а htpc отложен на потом...

Оффлайн Кулиш Евгений

  • Постоялец
  • ***
  • Сообщений: 197
    • ЖЖ
Re: Нет выхода звука 5.1
« Ответ #13 : 07 Августа 2016, 21:11:06 »
Поставил рядом TW64-112...
"Из каробки" не заработало...
Как проверить версию аудиодрайвера (какая установлена и какая последняя)?
Пс: сообщение №7 дополняю...

Оффлайн vita

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 2363
  • Да будет свет!
Re: Нет выхода звука 5.1
« Ответ #14 : 07 Августа 2016, 21:23:53 »
Попробуйте Pavucontrol - Регулятор громкости PulseAudio в меню Приложения->Аудио и видео.
Проверьте разные варианты конфигурации выходов звука, например,
Делай с нами, делай как мы, делай лучше нас!